# CVE-2019-11993: Path traversal in SimpliVity OmniCube; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; SimpliVity OmniStack for Lenovo; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; HPE SimpliVity 2600 Gen10

> Unauthenticated remote attackers can create or delete arbitrary files on HPE SimpliVity nodes via deprecated root APIs, compromising integrity and availability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8f22-pcx4-9xqm

## What is CVE-2019-11993?

CVE-2019-11993 is a high-severity path traversal vulnerability in SimpliVity OmniCube; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; SimpliVity OmniStack for Lenovo; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; HPE SimpliVity 2600 Gen10, published on 3 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security vulnerability has been identified in HPE SimpliVity 380 Gen 9, HPE SimpliVity 380 Gen 10, HPE SimpliVity 380 Gen 10 G, HPE SimpliVity 2600 Gen 10, SimpliVity OmniCube, SimpliVity OmniStack for Cisco, SimpliVity OmniStack for Lenovo and SimpliVity OmniStack for Dell nodes. Two now deprecated APIs run as root, accept a file name path, and can be used to create or delete arbitrary files on the nodes. These APIs do not require user authentication and are accessible over the management network, resulting in remote availability and integrity vulnerabilities For all customers running HPE OmniStack version 3.7.9 and earlier. HPE recommends upgrading the OmniStack software to version 3.7.10 or later, which contains a permanent resolution. Customers and partners who can upgrade to 3.7.10 should upgrade at the earliest convenience. For all customers and partners unable to upgrade their environments to the recommended version 3.7.10, HPE has created a Temporary Workaround https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=mmr_sf-EN_US000061675&withFrame for you to implement. All customer should upgrade to the recommended 3.7.10 or later version at the earliest convenience.

## Which versions are affected by CVE-2019-11993?

It affects 8 products.


Products: Hp Simplivity 2600 Gen10 Firmware, Hp Simplivity 380 Gen10 Firmware, Hp Simplivity 380 Gen10 G Firmware, Hp Simplivity 380 Gen9 Firmware, Hp Simplivity Omnicube Firmware, Hp Simplivity Omnistack for Cisco Firmware, Hp Simplivity Omnistack for Dell Firmware, Hp Simplivity Omnistack for Lenovo Firmware.

## How do I fix CVE-2019-11993?

No fix has been published for CVE-2019-11993 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-11993 being exploited?

There is no known exploitation of CVE-2019-11993 in the wild and no public exploit code.

## Other vulnerabilities in SimpliVity OmniCube; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; SimpliVity OmniStack for Lenovo; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; HPE SimpliVity 2600 Gen10

- [CVE-2019-11994](https://insights.sbomify.com/CVE-2019-11994/): Path traversal in HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11993 and fix it if it is affected.

What it is: CVE-2019-11993 is a high-severity path traversal vulnerability in SimpliVity OmniCube; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; SimpliVity OmniStack for Lenovo; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; HPE SimpliVity 2600 Gen10, published on 3 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11993 in the wild and no public exploit code.

Affected product: SimpliVity OmniCube; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; SimpliVity OmniStack for Lenovo; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; HPE SimpliVity 2600 Gen10. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11993/ (Markdown: https://insights.sbomify.com/CVE-2019-11993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11993
- OSV: https://osv.dev/vulnerability/CVE-2019-11993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11993/
Summaries are generated and may contain mistakes; the official description above is the record.
