# CVE-2019-11994: Path traversal in HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo

> Unauthenticated attackers can execute arbitrary manifest files via path traversal in the upgrade API, leading to remote code execution on HPE SimpliVity nodes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g4jw-5vhw-jpgg

## What is CVE-2019-11994?

CVE-2019-11994 is a critical path traversal vulnerability in HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo, published on 3 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security vulnerability has been identified in HPE SimpliVity 380 Gen 9, HPE SimpliVity 380 Gen 10, HPE SimpliVity 380 Gen 10 G, HPE SimpliVity 2600 Gen 10, SimpliVity OmniCube, SimpliVity OmniStack for Cisco, SimpliVity OmniStack for Lenovo and SimpliVity OmniStack for Dell nodes. An API is used to execute a command manifest file during upgrade does not correctly prevent directory traversal and so can be used to execute manifest files in arbitrary locations on the node. The API does not require user authentication and is accessible over the management network, resulting in the potential for unauthenticated remote execution of manifest files. For all customers running HPE OmniStack version 3.7.9 and earlier. HPE recommends upgrading the OmniStack software to version 3.7.10 or later, which contains a permanent resolution. Customers and partners who can upgrade to 3.7.10 should upgrade at the earliest convenience. For all customers and partners unable to upgrade their environments to the recommended version 3.7.10, HPE has created a Temporary Workaround https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=mmr_sf-EN_US000061901&withFrame for you to implement. All customer should upgrade to the recommended 3.7.10 or later version at the earliest convenience.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-11994?

It affects 8 products.


Products: Hp Simplivity 2600 Gen10 Firmware, Hp Simplivity 380 Gen10 Firmware, Hp Simplivity 380 Gen10 G Firmware, Hp Simplivity 380 Gen9 Firmware, Hp Simplivity Omnicube Firmware, Hp Simplivity Omnistack for Cisco Firmware, Hp Simplivity Omnistack for Dell Firmware, Hp Simplivity Omnistack for Lenovo Firmware.

## How do I fix CVE-2019-11994?

No fix has been published for CVE-2019-11994 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-11994 being exploited?

There is no known exploitation of CVE-2019-11994 in the wild and no public exploit code.

## Other vulnerabilities in HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo

- [CVE-2019-11993](https://insights.sbomify.com/CVE-2019-11993/): Path traversal in SimpliVity OmniCube; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen9; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; SimpliVity OmniStack for Lenovo; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; HPE SimpliVity 2600 Gen10 (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-11994 and fix it if it is affected.

What it is: CVE-2019-11994 is a critical path traversal vulnerability in HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo, published on 3 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-11994 in the wild and no public exploit code.

Affected product: HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-11994/ (Markdown: https://insights.sbomify.com/CVE-2019-11994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-11994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-11994
- OSV: https://osv.dev/vulnerability/CVE-2019-11994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-11994/
Summaries are generated and may contain mistakes; the official description above is the record.
