# CVE-2019-12000: Security feature bypass in HPE MSE Msg Gw application E-LTU

> Attackers can bypass remote access restrictions in HPE MSE Messaging Gateway when HTTPS is used between USSD and external services.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hccp-6fqj-76m5

## What is CVE-2019-12000?

CVE-2019-12000 is a medium-severity vulnerability in HPE MSE Msg Gw application E-LTU, published on 17 Jul 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

HPE has found a potential Remote Access Restriction Bypass in HPE MSE Msg Gw application E-LTU prior to version 3.2 when HTTPS is used between the USSD and an external USSD service logic application. Update to version 3.2 and update the HTTPS configuration as described in the HPE MSE Messaging Gateway Configuration and Operations Guide.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-12000?

It affects 1 product.


Products: Hp Mse Msg Gw Application E-Ltu.

## How do I fix CVE-2019-12000?

No fix has been published for CVE-2019-12000 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-12000 being exploited?

There is no known exploitation of CVE-2019-12000 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12000 and fix it if it is affected.

What it is: CVE-2019-12000 is a medium-severity vulnerability in HPE MSE Msg Gw application E-LTU, published on 17 Jul 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12000 in the wild and no public exploit code.

Affected product: HPE MSE Msg Gw application E-LTU. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12000/ (Markdown: https://insights.sbomify.com/CVE-2019-12000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12000
- OSV: https://osv.dev/vulnerability/CVE-2019-12000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12000/
Summaries are generated and may contain mistakes; the official description above is the record.
