# CVE-2019-12041: Regular Expression Denial of Service in remarkable

> Attackers can cause a denial of service in the remarkable JavaScript library by submitting a crafted CDATA section that triggers excessive regular expression processing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q22g-8fr4-qpj4

## What is CVE-2019-12041?

CVE-2019-12041 is a high-severity denial of service vulnerability in n/a, published on 13 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/common/html_re.js in remarkable 1.7.1 allows Regular Expression Denial of Service (ReDoS) via a CDATA section.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2019-12041?

2 open source packages ship an affected version, including remarkable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remarkable` | npm | All versions | 1.7.2 |
| `remarkable` | npm | All versions | 1.7.2 |

Products: Remarkable Project Remarkable.

## How do I fix CVE-2019-12041?

Upgrade remarkable to 1.7.2 or later.

## Is CVE-2019-12041 being exploited?

There is no known exploitation of CVE-2019-12041 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-12043](https://insights.sbomify.com/CVE-2019-12043/): Cross-site Scripting in remarkable (medium 6.1)
- [CVE-2017-16006](https://insights.sbomify.com/CVE-2017-16006/): XSS in Data URI in remarkable (medium 6.1)
- [CVE-2014-10065](https://insights.sbomify.com/CVE-2014-10065/): Content Injection in remarkable (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12041 and fix it if it is affected.

What it is: CVE-2019-12041 is a high-severity denial of service vulnerability in n/a, published on 13 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12041 in the wild and no public exploit code.

Affected packages and fixed versions:
- remarkable (npm): affected all versions; fixed in 1.7.2
- remarkable (npm): affected all versions; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12041/ (Markdown: https://insights.sbomify.com/CVE-2019-12041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12041
- OSV: https://osv.dev/vulnerability/CVE-2019-12041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12041/
Summaries are generated and may contain mistakes; the official description above is the record.
