{"answers":{"affected":"1 open source package ship an affected version, including supervisor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-12105 in the wild and no public exploit code.","fix":"Upgrade supervisor to 4.0.3 or later.","what":"CVE-2019-12105 is a high-severity missing authorization vulnerability in n/a, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-12105 and fix it if it is affected.\n\nWhat it is: CVE-2019-12105 is a high-severity missing authorization vulnerability in n/a, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-12105 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- supervisor (PyPI): affected all versions; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12105/ (Markdown: https://insights.sbomify.com/CVE-2019-12105/index.md)","id":"CVE-2019-12105","markdown":"https://insights.sbomify.com/CVE-2019-12105/index.md","name":"CVE-2019-12105","record":{"aliases":["ALPINE-CVE-2019-12105","DEBIAN-CVE-2019-12105","ECHO-7c49-586a-06bd","GHSA-6x94-2xr2-xgw3","PYSEC-2019-126","openSUSE-SU-2024:11414-1"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Supervisor process control","requires_auth":"none","summary":"Unauthenticated users can read logs or restart services if the inet_http_server is enabled without a password.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"supervisor","vendor":"supervisord"}],"cvss":{"score":8.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing authorization in n/a","id":"CVE-2019-12105","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Use after free in n/a","id":"CVE-2019-12106"},"packages":[{"ecosystem":"PyPI","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"supervisor","purl":"pkg:pypi/supervisor","source":"PYSEC-2019-126"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.1.0-1.8"],"introduced":["0"],"last_affected":[],"package":"supervisor","purl":"pkg:rpm/opensuse/supervisor\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11414-1"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2019-12104"},"products":["n/a"],"published":"2019-09-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Unauthenticated users can read logs or restart services if the inet_http_server is enabled without a password.","url":"https://insights.sbomify.com/CVE-2019-12105/"}