# CVE-2019-12105: Missing authorization in n/a

> Unauthenticated users can read logs or restart services if the inet_http_server is enabled without a password.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-12105, DEBIAN-CVE-2019-12105, ECHO-7c49-586a-06bd, GHSA-6x94-2xr2-xgw3, PYSEC-2019-126, openSUSE-SU-2024:11414-1

## What is CVE-2019-12105?

CVE-2019-12105 is a high-severity missing authorization vulnerability in n/a, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service. Note: The maintainer responded that the affected component, inet_http_server, is not enabled by default but if the user enables it and does not set a password, Supervisor logs a warning message. The maintainer indicated the ability to run an open server will not be removed but an additional warning was added to the documentation

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2019-12105?

1 open source package ship an affected version, including supervisor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `supervisor` | PyPI | All versions | 4.0.3 |
| `supervisor` | openSUSE:Tumbleweed | All versions | 4.1.0-1.8 |

Products: Supervisord Supervisor.

## How do I fix CVE-2019-12105?

Upgrade supervisor to 4.0.3 or later.

## Is CVE-2019-12105 being exploited?

There is no known exploitation of CVE-2019-12105 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12105 and fix it if it is affected.

What it is: CVE-2019-12105 is a high-severity missing authorization vulnerability in n/a, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12105 in the wild and no public exploit code.

Affected packages and fixed versions:
- supervisor (PyPI): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12105/ (Markdown: https://insights.sbomify.com/CVE-2019-12105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12105
- OSV: https://osv.dev/vulnerability/CVE-2019-12105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12105/
Summaries are generated and may contain mistakes; the official description above is the record.
