CVE-2019-12139 ezplatform-admin-ui Cross-site Scripting (XSS) vulnerability
Cross-site scripting in eZ Platform Admin UI allows attackers to inject scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-12139?
CVE-2019-12139 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An XSS issue was discovered in the Admin UI in eZ Platform 2.x. This affects ezplatform-admin-ui 1.3.x before 1.3.5 and 1.4.x before 1.4.4, and ezplatform-page-builder 1.1.x before 1.1.5 and 1.2.x before 1.2.4.
Weakness: CWE-79
Which versions are affected by CVE-2019-12139?
4 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
ezsystems/ezplatform-admin-ui Packagist | From 1.3 | 1.3.5 |
ezsystems/ezplatform-admin-ui Packagist | From 1.3 | 1.3.5 |
ezsystems/ezplatform-admin-ui Packagist | From 1.4 | 1.4.4 |
ezsystems/ezplatform-admin-ui Packagist | From 1.4 | 1.4.4 |
Products include Ez Ezplatform-Admin-Ui, Ez Ezplatform-Page-Builder.
How do I fix CVE-2019-12139?
Upgrade ezsystems/ezplatform-admin-ui to a fixed version for your release line: 1.3.5 or 1.4.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-12139 being exploited?
There is no known exploitation of CVE-2019-12139 in the wild and no public exploit code.
Sources
Also known as GHSA-99rh-vxmc-7wgf.