{"answers":{"affected":"4 open source packages ship an affected version, including ezsystems/ezplatform-admin-ui. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-12139 in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezplatform-admin-ui to a fixed version for your release line: 1.3.5 or 1.4.4.","what":"CVE-2019-12139 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-12139 and fix it if it is affected.\n\nWhat it is: CVE-2019-12139 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-12139 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.3; fixed in 1.3.5\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.3; fixed in 1.3.5\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.4; fixed in 1.4.4\n- ezsystems/ezplatform-admin-ui (Packagist): affected from 1.4; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12139/ (Markdown: https://insights.sbomify.com/CVE-2019-12139/index.md)","id":"CVE-2019-12139","markdown":"https://insights.sbomify.com/CVE-2019-12139/index.md","name":"CVE-2019-12139","record":{"aliases":["GHSA-99rh-vxmc-7wgf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"eZ Platform Admin UI","requires_auth":"none","summary":"Cross-site scripting in eZ Platform Admin UI allows attackers to inject scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ezplatform-admin-ui","vendor":"ez"},{"product":"ezplatform-page-builder","vendor":"ez"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An XSS issue was discovered in the Admin UI in eZ Platform 2.x. This affects ezplatform-admin-ui 1.3.x before 1.3.5 and 1.4.x before 1.4.4, and ezplatform-page-builder 1.1.x before 1.1.5 and 1.2.x before 1.2.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ezplatform-admin-ui Cross-site Scripting (XSS) vulnerability","id":"CVE-2019-12139","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":4,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2019-12143"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["1.3"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":null,"source":"GHSA-99rh-vxmc-7wgf"},{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["1.3"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":"pkg:composer/ezsystems/ezplatform-admin-ui","source":"GHSA-99rh-vxmc-7wgf"},{"ecosystem":"Packagist","fixed":["1.4.4"],"introduced":["1.4"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":null,"source":"GHSA-99rh-vxmc-7wgf"},{"ecosystem":"Packagist","fixed":["1.4.4"],"introduced":["1.4"],"last_affected":[],"package":"ezsystems/ezplatform-admin-ui","purl":"pkg:composer/ezsystems/ezplatform-admin-ui","source":"GHSA-99rh-vxmc-7wgf"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2019-12138"},"products":["n/a"],"published":"2019-05-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting in eZ Platform Admin UI allows attackers to inject scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2019-12139/"}