# CVE-2019-12149: silverstripe restfulserver and registry modules SQL injection vulnerability

> Attackers can execute arbitrary SQL commands in SilverStripe RESTful Server and Registry modules, potentially compromising database integrity and confidentiality.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4j6v-3895-8g2j

## What is CVE-2019-12149?

CVE-2019-12149 is a critical SQL injection vulnerability in n/a, published on 11 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL injection vulnerability in silverstripe/restfulserver module 1.0.x before 1.0.9, 2.0.x before 2.0.4, and 2.1.x before 2.1.2 and silverstripe/registry module 2.1.x before 2.1.1 and 2.2.x before 2.2.1 allows attackers to execute arbitrary SQL commands.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-12149?

10 open source packages ship an affected version, including silverstripe/restfulserver and silverstripe/registry. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/restfulserver` | Packagist | From 1.0.0 | 1.0.9 |
| `silverstripe/restfulserver` | Packagist | From 1.0.0 | 1.0.9 |
| `silverstripe/restfulserver` | Packagist | From 2.0.0 | 2.0.4 |
| `silverstripe/restfulserver` | Packagist | From 2.0.0 | 2.0.4 |
| `silverstripe/restfulserver` | Packagist | From 2.1.0 | 2.1.2 |
| `silverstripe/restfulserver` | Packagist | From 2.1.0 | 2.1.2 |
| `silverstripe/registry` | Packagist | From 2.1.0 | 2.1.1 |
| `silverstripe/registry` | Packagist | From 2.1.0 | 2.1.1 |
| `silverstripe/registry` | Packagist | From 2.2.0 | 2.2.1 |
| `silverstripe/registry` | Packagist | From 2.2.0 | 2.2.1 |

Products: Silverstripe Registry, Silverstripe Restfulserver.

## How do I fix CVE-2019-12149?

Upgrade silverstripe/restfulserver to a fixed version for your release line: 1.0.9, 2.0.4 or 2.1.2.

## Is CVE-2019-12149 being exploited?

There is no known exploitation of CVE-2019-12149 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12149 and fix it if it is affected.

What it is: CVE-2019-12149 is a critical SQL injection vulnerability in n/a, published on 11 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12149 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/restfulserver (Packagist): affected from 1.0.0; fixed in 1.0.9
- silverstripe/restfulserver (Packagist): affected from 1.0.0; fixed in 1.0.9
- silverstripe/restfulserver (Packagist): affected from 2.0.0; fixed in 2.0.4
- silverstripe/restfulserver (Packagist): affected from 2.0.0; fixed in 2.0.4
- silverstripe/restfulserver (Packagist): affected from 2.1.0; fixed in 2.1.2
- silverstripe/restfulserver (Packagist): affected from 2.1.0; fixed in 2.1.2
- silverstripe/registry (Packagist): affected from 2.1.0; fixed in 2.1.1
- silverstripe/registry (Packagist): affected from 2.1.0; fixed in 2.1.1
- silverstripe/registry (Packagist): affected from 2.2.0; fixed in 2.2.1
- silverstripe/registry (Packagist): affected from 2.2.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12149/ (Markdown: https://insights.sbomify.com/CVE-2019-12149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12149
- OSV: https://osv.dev/vulnerability/CVE-2019-12149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12149/
Summaries are generated and may contain mistakes; the official description above is the record.
