CVE-2019-12203 Session fixation in change password form
Attackers can hijack user sessions via the change password form in SilverStripe, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-12203?
CVE-2019-12203 is a medium-severity authentication bypass vulnerability in Silverstripe Silverstripe, published on 25 Sep 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
SilverStripe through 4.3.3 allows session fixation in the "change password" form.
Weakness: CWE-384
Which versions are affected by CVE-2019-12203?
8 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/framework Packagist | From 3.6.0 | 3.6.8 |
silverstripe/framework Packagist | From 3.6.0 | 3.6.8 |
silverstripe/framework Packagist | From 3.7.0 | 3.7.4 |
silverstripe/framework Packagist | From 3.7.0 | 3.7.4 |
silverstripe/framework Packagist | From 4.0.0 | 4.3.5 |
silverstripe/framework Packagist | From 4.0.0 | 4.3.5 |
2 more packages
silverstripe/framework Packagist | From 4.4.0 | 4.4.4 |
silverstripe/framework Packagist | From 4.4.0 | 4.4.4 |
Products include Silverstripe Silverstripe.
How do I fix CVE-2019-12203?
Upgrade silverstripe/framework to a fixed version for your release line: 3.6.8, 3.7.4, 4.3.5 or 4.4.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-12203 being exploited?
There is no known exploitation of CVE-2019-12203 in the wild and no public exploit code.
Other vulnerabilities in Silverstripe Silverstripe
Sources
Also known as GHSA-w7r7-r8r9-vrg2.