# CVE-2019-12203: Session fixation in change password form

> Attackers can hijack user sessions via the change password form in SilverStripe, leading to account takeover.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:P/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w7r7-r8r9-vrg2

## What is CVE-2019-12203?

CVE-2019-12203 is a medium-severity authentication bypass vulnerability in Silverstripe Silverstripe, published on 25 Sep 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

SilverStripe through 4.3.3 allows session fixation in the "change password" form.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2019-12203?

8 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 3.6.0 | 3.6.8 |
| `silverstripe/framework` | Packagist | From 3.6.0 | 3.6.8 |
| `silverstripe/framework` | Packagist | From 3.7.0 | 3.7.4 |
| `silverstripe/framework` | Packagist | From 3.7.0 | 3.7.4 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.4.0 | 4.4.4 |
| `silverstripe/framework` | Packagist | From 4.4.0 | 4.4.4 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-12203?

Upgrade silverstripe/framework to a fixed version for your release line: 3.6.8, 3.7.4, 4.3.5 or 4.4.4.

## Is CVE-2019-12203 being exploited?

There is no known exploitation of CVE-2019-12203 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12203 and fix it if it is affected.

What it is: CVE-2019-12203 is a medium-severity authentication bypass vulnerability in Silverstripe Silverstripe, published on 25 Sep 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12203 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 3.6.0; fixed in 3.6.8
- silverstripe/framework (Packagist): affected from 3.6.0; fixed in 3.6.8
- silverstripe/framework (Packagist): affected from 3.7.0; fixed in 3.7.4
- silverstripe/framework (Packagist): affected from 3.7.0; fixed in 3.7.4
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.4.0; fixed in 4.4.4
- silverstripe/framework (Packagist): affected from 4.4.0; fixed in 4.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12203/ (Markdown: https://insights.sbomify.com/CVE-2019-12203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12203
- OSV: https://osv.dev/vulnerability/CVE-2019-12203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12203/
Summaries are generated and may contain mistakes; the official description above is the record.
