# CVE-2019-12204: Missing warning can lead to unauthenticated admin access in SilverStripe

> Attackers can gain unauthenticated admin access if the install.php file remains in the public webroot, requiring manual removal or configuration changes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cg8j-8w52-735v

## What is CVE-2019-12204?

CVE-2019-12204 is a critical authentication bypass vulnerability in Silverstripe Silverstripe, published on 25 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public webroot can lead to unauthenticated admin access.

## Which versions are affected by CVE-2019-12204?

4 open source packages ship an affected version, including silverstripe/cms and silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/cms` | Packagist | From 4.4.0 | 4.4.4 |
| `silverstripe/cms` | Packagist | From 4.4.0 | 4.4.4 |
| `silverstripe/framework` | Packagist | From 4.1.0 | 4.3.5 |
| `silverstripe/framework` | Packagist | From 4.1.0 | 4.3.5 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-12204?

Upgrade silverstripe/cms to 4.4.4 or later.

## Is CVE-2019-12204 being exploited?

There is no known exploitation of CVE-2019-12204 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)
- [CVE-2020-9280](https://insights.sbomify.com/CVE-2020-9280/): SilverStripe Folders migrated from 3.x may be unsafe to upload to (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12204 and fix it if it is affected.

What it is: CVE-2019-12204 is a critical authentication bypass vulnerability in Silverstripe Silverstripe, published on 25 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12204 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/cms (Packagist): affected from 4.4.0; fixed in 4.4.4
- silverstripe/cms (Packagist): affected from 4.4.0; fixed in 4.4.4
- silverstripe/framework (Packagist): affected from 4.1.0; fixed in 4.3.5
- silverstripe/framework (Packagist): affected from 4.1.0; fixed in 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12204/ (Markdown: https://insights.sbomify.com/CVE-2019-12204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12204
- OSV: https://osv.dev/vulnerability/CVE-2019-12204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12204/
Summaries are generated and may contain mistakes; the official description above is the record.
