CVE-2019-12274 Rancher Privilege Escalation Vulnerability

High 8.8 Published Updated

Unprivileged users with node deployment rights can escalate to admin by exfiltrating sensitive kubeconfig files via node driver options.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-12274?

CVE-2019-12274 is a high-severity vulnerability in n/a, published on 6 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Rancher 1 and 2 through 2.2.3, unprivileged users (if allowed to deploy nodes) can gain admin access to the Rancher management plane because node driver options intentionally allow posting certain data to the cloud. The problem is that a user could choose to post a sensitive file such as /root/.kube/config or /var/lib/rancher/management-state/cred/kubeconfig-system.yaml.

Weakness: CWE-862, CWE-668

Which versions are affected by CVE-2019-12274?

5 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoAll versions1.6.27, 2.2.4+incompatible
github.com/rancher/rancher GoAll versions1.6.27
github.com/rancher/rancher GoAll versions1.6.27
github.com/rancher/rancher GoFrom 2.0.02.2.4
github.com/rancher/rancher GoFrom 2.0.02.2.4

Products include Suse Rancher.

How do I fix CVE-2019-12274?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 1.6.27, 2.2.4+incompatible or 2.2.4.

Is CVE-2019-12274 being exploited?

There is no known exploitation of CVE-2019-12274 in the wild and no public exploit code.

Sources

Also known as GHSA-gc62-j469-9gjm, GO-2023-1991.

Is CVE-2019-12274 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free