# CVE-2019-12274: Rancher Privilege Escalation Vulnerability

> Unprivileged users with node deployment rights can escalate to admin by exfiltrating sensitive kubeconfig files via node driver options.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gc62-j469-9gjm, GO-2023-1991

## What is CVE-2019-12274?

CVE-2019-12274 is a high-severity vulnerability in n/a, published on 6 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Rancher 1 and 2 through 2.2.3, unprivileged users (if allowed to deploy nodes) can gain admin access to the Rancher management plane because node driver options intentionally allow posting certain data to the cloud. The problem is that a user could choose to post a sensitive file such as /root/.kube/config or /var/lib/rancher/management-state/cred/kubeconfig-system.yaml.

Weakness: CWE-862 (Missing Authorization), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2019-12274?

5 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | 1.6.27, 2.2.4+incompatible |
| `github.com/rancher/rancher` | Go | All versions | 1.6.27 |
| `github.com/rancher/rancher` | Go | All versions | 1.6.27 |
| `github.com/rancher/rancher` | Go | From 2.0.0 | 2.2.4 |
| `github.com/rancher/rancher` | Go | From 2.0.0 | 2.2.4 |

Products: Suse Rancher.

## How do I fix CVE-2019-12274?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 1.6.27, 2.2.4+incompatible or 2.2.4.

## Is CVE-2019-12274 being exploited?

There is no known exploitation of CVE-2019-12274 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12274 and fix it if it is affected.

What it is: CVE-2019-12274 is a high-severity vulnerability in n/a, published on 6 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12274 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; fixed in 1.6.27, 2.2.4+incompatible
- github.com/rancher/rancher (Go): affected all versions; fixed in 1.6.27
- github.com/rancher/rancher (Go): affected all versions; fixed in 1.6.27
- github.com/rancher/rancher (Go): affected from 2.0.0; fixed in 2.2.4
- github.com/rancher/rancher (Go): affected from 2.0.0; fixed in 2.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12274/ (Markdown: https://insights.sbomify.com/CVE-2019-12274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12274
- OSV: https://osv.dev/vulnerability/CVE-2019-12274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12274/
Summaries are generated and may contain mistakes; the official description above is the record.
