# CVE-2019-12277: Blogifier does not properly restrict APIs

> Attackers can exploit missing path restrictions in Blogifier APIs to access or modify arbitrary files on the server.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qcx4-gfh8-w5p5

## What is CVE-2019-12277?

CVE-2019-12277 is a critical path traversal vulnerability in n/a, published on 22 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Blogifier 2.3 before 2019-05-11 does not properly restrict APIs, as demonstrated by missing checks for .. in a pathname.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-12277?

2 open source packages ship an affected version, including Blogifier.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Blogifier.Core` | NuGet | All versions | 2.5.5 |
| `Blogifier.Core` | NuGet | All versions | 2.5.5 |

Products: Blogifier Blogifier.

## How do I fix CVE-2019-12277?

Upgrade Blogifier.Core to 2.5.5 or later.

## Is CVE-2019-12277 being exploited?

There is no known exploitation of CVE-2019-12277 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-35569](https://insights.sbomify.com/CVE-2022-35569/): Blogifier v3.0 was discovered to contain an arbitrary file upload vulnerability at /api/storage/upload/PostImage. (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12277 and fix it if it is affected.

What it is: CVE-2019-12277 is a critical path traversal vulnerability in n/a, published on 22 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12277 in the wild and no public exploit code.

Affected packages and fixed versions:
- Blogifier.Core (NuGet): affected all versions; fixed in 2.5.5
- Blogifier.Core (NuGet): affected all versions; fixed in 2.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12277/ (Markdown: https://insights.sbomify.com/CVE-2019-12277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12277
- OSV: https://osv.dev/vulnerability/CVE-2019-12277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12277/
Summaries are generated and may contain mistakes; the official description above is the record.
