CVE-2019-12303 Rancher code injection via fluentd config commands

High 8.8 Published Updated

Project owners can inject fluentd configuration to execute arbitrary commands or read files within the fluentd container.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-12303?

CVE-2019-12303 is a high-severity command injection vulnerability in n/a, published on 6 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.

Weakness: CWE-74

Which versions are affected by CVE-2019-12303?

3 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.

PackageAffectedFixed in
github.com/rancher/rancher GoFrom 2.0.02.2.4
github.com/rancher/rancher GoFrom 2.0.02.2.4
github.com/rancher/rancher GoFrom 2.0.0+incompatible2.2.4+incompatible

Products include Suse Rancher.

How do I fix CVE-2019-12303?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.2.4 or 2.2.4+incompatible.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2019-12303 being exploited?

There is no known exploitation of CVE-2019-12303 in the wild and no public exploit code.

Sources

Also known as GHSA-53pj-67m4-9w98, GO-2024-2762.

Is CVE-2019-12303 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free