# CVE-2019-12303: Rancher code injection via fluentd config commands

> Project owners can inject fluentd configuration to execute arbitrary commands or read files within the fluentd container.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-53pj-67m4-9w98, GO-2024-2762

## What is CVE-2019-12303?

CVE-2019-12303 is a high-severity command injection vulnerability in n/a, published on 6 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-12303?

3 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.0.0 | 2.2.4 |
| `github.com/rancher/rancher` | Go | From 2.0.0 | 2.2.4 |
| `github.com/rancher/rancher` | Go | From 2.0.0+incompatible | 2.2.4+incompatible |

Products: Suse Rancher.

## How do I fix CVE-2019-12303?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.2.4 or 2.2.4+incompatible.

## Is CVE-2019-12303 being exploited?

There is no known exploitation of CVE-2019-12303 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12303 and fix it if it is affected.

What it is: CVE-2019-12303 is a high-severity command injection vulnerability in n/a, published on 6 Jun 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12303 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.0.0; fixed in 2.2.4
- github.com/rancher/rancher (Go): affected from 2.0.0; fixed in 2.2.4
- github.com/rancher/rancher (Go): affected from 2.0.0+incompatible; fixed in 2.2.4+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12303/ (Markdown: https://insights.sbomify.com/CVE-2019-12303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12303
- OSV: https://osv.dev/vulnerability/CVE-2019-12303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12303/
Summaries are generated and may contain mistakes; the official description above is the record.
