# CVE-2019-12308: Django Cross-site Scripting in AdminURLFieldWidget

> Attackers can inject malicious JavaScript into the Django Admin URL field widget, potentially executing code in the context of an admin user.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-12308, DEBIAN-CVE-2019-12308, DLA-1814-1, GHSA-7rp2-fm2h-wchj, PYSEC-2019-79, SUSE-SU-2019:2034-1, UBUNTU-CVE-2019-12308

## What is CVE-2019-12308?

CVE-2019-12308 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Django 1.11 before 1.11.21, 2.1 before 2.1.9, and 2.2 before 2.2.2. The clickable Current URL value displayed by the AdminURLFieldWidget displays the provided value without validating it as a safe URL. Thus, an unvalidated value stored in the database, or a value provided as a URL query parameter payload, could result in an clickable JavaScript link.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-12308?

7 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.11a1 | 1.11.21 |
| `django` | PyPI | From 2.1 | 2.1.9, 1.11.21, 2.2.2 |
| `django` | PyPI | From 2.1a1 | 2.1.9 |
| `django` | PyPI | From 2.2a1 | 2.2.2 |
| `Django` | PyPI | From 1.11a1 | 1.11.21 |
| `Django` | PyPI | From 2.1a1 | 2.1.9 |
| `Django` | PyPI | From 2.2a1 | 2.2.2 |
| `python-Django1` | SUSE:OpenStack Cloud 9 | All versions | 1.11.20-3.6.1 |
| `python-Django1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.20-3.6.1 |

Products: Djangoproject Django.

## How do I fix CVE-2019-12308?

Upgrade django to a fixed version for your release line: 1.11.21, 2.1.9 or 2.2.2.

## Is CVE-2019-12308 being exploited?

There is no known exploitation of CVE-2019-12308 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12308 and fix it if it is affected.

What it is: CVE-2019-12308 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12308 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.11a1; fixed in 1.11.21
- django (PyPI): affected from 2.1; fixed in 2.1.9, 1.11.21, 2.2.2
- django (PyPI): affected from 2.1a1; fixed in 2.1.9
- django (PyPI): affected from 2.2a1; fixed in 2.2.2
- Django (PyPI): affected from 1.11a1; fixed in 1.11.21
- Django (PyPI): affected from 2.1a1; fixed in 2.1.9
- Django (PyPI): affected from 2.2a1; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12308/ (Markdown: https://insights.sbomify.com/CVE-2019-12308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12308
- OSV: https://osv.dev/vulnerability/CVE-2019-12308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12308/
Summaries are generated and may contain mistakes; the official description above is the record.
