{"answers":{"affected":"2 open source packages ship an affected version, including shave. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-12313 in the wild and no public exploit code.","fix":"Upgrade shave to 2.5.3 or later.","what":"CVE-2019-12313 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-12313 and fix it if it is affected.\n\nWhat it is: CVE-2019-12313 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-12313 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shave (npm): affected all versions; fixed in 2.5.3\n- shave (npm): affected all versions; fixed in 2.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12313/ (Markdown: https://insights.sbomify.com/CVE-2019-12313/index.md)","id":"CVE-2019-12313","markdown":"https://insights.sbomify.com/CVE-2019-12313/index.md","name":"CVE-2019-12313","record":{"aliases":["GHSA-gh4g-3gm9-5wrq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"Cross-site scripting vulnerability in the Shave JavaScript library allows attackers to execute arbitrary scripts via mishandled output encoding.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"shave","vendor":"dollarshaveclub"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"XSS exists in Shave before 2.5.3 because output encoding is mishandled during the overwrite of an HTML element.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in shave","id":"CVE-2019-12313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Path traversal in n/a","id":"CVE-2019-12314"},"packages":[{"ecosystem":"npm","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"shave","purl":null,"source":"GHSA-gh4g-3gm9-5wrq"},{"ecosystem":"npm","fixed":["2.5.3"],"introduced":["0"],"last_affected":[],"package":"shave","purl":"pkg:npm/shave","source":"GHSA-gh4g-3gm9-5wrq"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2019-12312"},"products":["n/a"],"published":"2019-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the Shave JavaScript library allows attackers to execute arbitrary scripts via mishandled output encoding.","url":"https://insights.sbomify.com/CVE-2019-12313/"}