# CVE-2019-12313: Cross-Site Scripting in shave

> Cross-site scripting vulnerability in the Shave JavaScript library allows attackers to execute arbitrary scripts via mishandled output encoding.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gh4g-3gm9-5wrq

## What is CVE-2019-12313?

CVE-2019-12313 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XSS exists in Shave before 2.5.3 because output encoding is mishandled during the overwrite of an HTML element.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-12313?

2 open source packages ship an affected version, including shave. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shave` | npm | All versions | 2.5.3 |
| `shave` | npm | All versions | 2.5.3 |

Products: Dollarshaveclub Shave.

## How do I fix CVE-2019-12313?

Upgrade shave to 2.5.3 or later.

## Is CVE-2019-12313 being exploited?

There is no known exploitation of CVE-2019-12313 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12313 and fix it if it is affected.

What it is: CVE-2019-12313 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 May 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12313 in the wild and no public exploit code.

Affected packages and fixed versions:
- shave (npm): affected all versions; fixed in 2.5.3
- shave (npm): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12313/ (Markdown: https://insights.sbomify.com/CVE-2019-12313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12313
- OSV: https://osv.dev/vulnerability/CVE-2019-12313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12313/
Summaries are generated and may contain mistakes; the official description above is the record.
