# CVE-2019-12331: XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue

> An attacker can exploit an XXE vulnerability in PhpSpreadsheet to read sensitive files or execute code by bypassing entity checks via double-encoded payloads.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vvwv-h69m-wg6f

## What is CVE-2019-12331?

CVE-2019-12331 is a high-severity vulnerability in n/a, published on 7 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PHPOffice PhpSpreadsheet before 1.8.0 has an XXE issue. The XmlScanner decodes the sheet1.xml from an .xlsx to utf-8 if something else than UTF-8 is declared in the header. This was a security measurement to prevent CVE-2018-19277 but the fix is not sufficient. By double-encoding the the xml payload to utf-7 it is possible to bypass the check for the string ‚<!ENTITY‘ and thus allowing for an xml external entity processing (XXE) attack.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-12331?

4 open source packages ship an affected version, including phpoffice/phpexcel and phpoffice/phpspreadsheet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.8.0 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.8.0 |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2019-12331?

Upgrade to a fixed version.

## Is CVE-2019-12331 being exploited?

There is no known exploitation of CVE-2019-12331 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)
- [CVE-2024-56366](https://insights.sbomify.com/CVE-2024-56366/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12331 and fix it if it is affected.

What it is: CVE-2019-12331 is a high-severity vulnerability in n/a, published on 7 Nov 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12331 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.8.0
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12331/ (Markdown: https://insights.sbomify.com/CVE-2019-12331/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12331
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12331
- OSV: https://osv.dev/vulnerability/CVE-2019-12331

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12331/
Summaries are generated and may contain mistakes; the official description above is the record.
