# CVE-2019-12397: Cross-site scripting in Apache Ranger


- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fpqp-v323-44xv

## What is CVE-2019-12397?

CVE-2019-12397 is a medium-severity vulnerability in Apache Ranger, published on 8 Aug 2019. 

### Official description

Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-12397?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ranger:ranger` | Maven | From 0.7.0 | 2.0.0 |
| `org.apache.ranger:ranger` | Maven | From 0.7.0 | 2.0.0 |

Products: Apache Ranger.

## How do I fix CVE-2019-12397?

Upgrade org.apache.ranger:ranger to 2.0.0 or later.

## Is CVE-2019-12397 being exploited?

There is no known exploitation of CVE-2019-12397 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ranger

- [CVE-2026-28672](https://insights.sbomify.com/CVE-2026-28672/): Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder (critical 9.8)
- [CVE-2026-32227](https://insights.sbomify.com/CVE-2026-32227/): Apache Ranger: SQL Injection vulnerability in lookup functionality (critical 9.8)
- [CVE-2026-40920](https://insights.sbomify.com/CVE-2026-40920/): Apache Ranger: Privilege Escalation via URL Parameter (critical 9.8)
- [CVE-2026-42537](https://insights.sbomify.com/CVE-2026-42537/): Apache Ranger: Remote Code Execution via JDBC URL Injection (critical 9.8)
- [CVE-2026-44416](https://insights.sbomify.com/CVE-2026-44416/): Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12397 and fix it if it is affected.

What it is: CVE-2019-12397 is a medium-severity vulnerability in Apache Ranger, published on 8 Aug 2019. 
Exploitation: There is no known exploitation of CVE-2019-12397 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ranger:ranger (Maven): affected from 0.7.0; fixed in 2.0.0
- org.apache.ranger:ranger (Maven): affected from 0.7.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12397/ (Markdown: https://insights.sbomify.com/CVE-2019-12397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12397
- OSV: https://osv.dev/vulnerability/CVE-2019-12397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12397/
Summaries are generated and may contain mistakes; the official description above is the record.
