CVE-2019-12401 Apache Solr vulnerable to XML Bomb

High 7.5 Published Updated

Attackers can cause denial of service in Apache Solr by sending malicious XML payloads that trigger excessive resource consumption during parsing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-12401?

CVE-2019-12401 is a high-severity denial of service vulnerability in Apache Solr, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Solr versions 1.3.0 to 1.4.1, 3.1.0 to 3.6.2 and 4.0.0 to 4.10.4 are vulnerable to an XML resource consumption attack (a.k.a. Lol Bomb) via it’s update handler.?By leveraging XML DOCTYPE and ENTITY type elements, the attacker can create a pattern that will expand when the server parses the XML causing OOMs.

Weakness: CWE-776

Which versions are affected by CVE-2019-12401?

2 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.

PackageAffectedFixed in
org.apache.solr:solr-core MavenAll versions5.0.0
org.apache.solr:solr-core MavenAll versions5.0.0

Products include Apache Solr.

How do I fix CVE-2019-12401?

Upgrade org.apache.solr:solr-core to 5.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-12401 being exploited?

There is no known exploitation of CVE-2019-12401 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-jq2w-w7v2-69q5.

Is CVE-2019-12401 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free