# CVE-2019-12401: Apache Solr vulnerable to XML Bomb

> Attackers can cause denial of service in Apache Solr by sending malicious XML payloads that trigger excessive resource consumption during parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jq2w-w7v2-69q5

## What is CVE-2019-12401?

CVE-2019-12401 is a high-severity denial of service vulnerability in Apache Solr, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Solr versions 1.3.0 to 1.4.1, 3.1.0 to 3.6.2 and 4.0.0 to 4.10.4 are vulnerable to an XML resource consumption attack (a.k.a. Lol Bomb) via it’s update handler.?By leveraging XML DOCTYPE and ENTITY type elements, the attacker can create a pattern that will expand when the server parses the XML causing OOMs.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2019-12401?

2 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 5.0.0 |
| `org.apache.solr:solr-core` | Maven | All versions | 5.0.0 |

Products: Apache Solr.

## How do I fix CVE-2019-12401?

Upgrade org.apache.solr:solr-core to 5.0.0 or later.

## Is CVE-2019-12401 being exploited?

There is no known exploitation of CVE-2019-12401 in the wild and no public exploit code.

Public exploit code:

- CVE-2019-12401: XML Bomb in Apache Solr (github_poc): https://github.com/mbadanoiu/CVE-2019-12401

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12401 and fix it if it is affected.

What it is: CVE-2019-12401 is a high-severity denial of service vulnerability in Apache Solr, published on 10 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12401 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 5.0.0
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12401/ (Markdown: https://insights.sbomify.com/CVE-2019-12401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12401
- OSV: https://osv.dev/vulnerability/CVE-2019-12401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12401/
Summaries are generated and may contain mistakes; the official description above is the record.
