# CVE-2019-12409: Unrestricted upload of file with dangerous type in Apache Solr

> Attackers can execute arbitrary code on Apache Solr servers if the default JMX configuration is exposed without authentication.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2289-pqfq-6wx7

## What is CVE-2019-12409?

CVE-2019-12409 is a critical vulnerability in Apache Solr, published on 18 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The 8.1.1 and 8.2.0 releases of Apache Solr contain an insecure setting for the ENABLE_REMOTE_JMX_OPTS configuration option in the default solr.in.sh configuration file shipping with Solr. If you use the default solr.in.sh file from the affected releases, then JMX monitoring will be enabled and exposed on RMI_PORT (default=18983), without any authentication. If this port is opened for inbound traffic in your firewall, then anyone with network access to your Solr nodes will be able to access JMX, which may in turn allow them to upload malicious code for execution on the Solr server.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-12409?

2 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 8.1.1 | 8.3.0 |
| `org.apache.solr:solr-core` | Maven | From 8.1.1 | 8.3.0 |

Products: Apache Solr.

## How do I fix CVE-2019-12409?

Upgrade org.apache.solr:solr-core to 8.3.0 or later.

## Is CVE-2019-12409 being exploited?

There is no known exploitation of CVE-2019-12409 in the wild and no public exploit code.

Public exploit code:

- Apache Solr RCE (ENABLE_REMOTE_JMX_OPTS="true") (github_poc): https://github.com/jas502n/CVE-2019-12409
- CVE-2019-12409: RCE Vulnerability Due to Bad Defalut Config in Apache Solr (github_poc): https://github.com/mbadanoiu/CVE-2019-12409

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12409 and fix it if it is affected.

What it is: CVE-2019-12409 is a critical vulnerability in Apache Solr, published on 18 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12409 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 8.1.1; fixed in 8.3.0
- org.apache.solr:solr-core (Maven): affected from 8.1.1; fixed in 8.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12409/ (Markdown: https://insights.sbomify.com/CVE-2019-12409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12409
- OSV: https://osv.dev/vulnerability/CVE-2019-12409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12409/
Summaries are generated and may contain mistakes; the official description above is the record.
