CVE-2019-12413 Users able to query database metadata in Apache Superset

Medium 5.3 Published Updated

Attackers can read database metadata from unauthorized databases via crafted queries, exposing sensitive schema information in Apache Superset.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-12413?

CVE-2019-12413 is a medium-severity missing authorization vulnerability in Apache Superset, published on 16 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Incubator Superset before 0.31 user could query database metadata information from a database he has no access to, by using a specially crafted complex query.

Which versions are affected by CVE-2019-12413?

3 open source packages ship an affected version, including apache-superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions0.31
apache-superset PyPIAll versions0.31.0
apache-superset PyPIAll versions0.31.0

Products include Apache Superset.

How do I fix CVE-2019-12413?

Upgrade apache-superset to a fixed version for your release line: 0.31 or 0.31.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2019-12413 being exploited?

There is no known exploitation of CVE-2019-12413 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as GHSA-p5w7-qmq6-pmjr, PYSEC-2019-172.

Is CVE-2019-12413 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free