CVE-2019-12414 Users can view database names in Apache Superset

Medium 5.3 Published Updated

An attacker can view unauthorized database names in the SQLLab dropdown list, exposing sensitive metadata.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-12414?

CVE-2019-12414 is a medium-severity vulnerability in Apache Superset, published on 16 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Incubator Superset before 0.32, a user can view database names that he has no access to on a dropdown list in SQLLab

Weakness: CWE-200

Which versions are affected by CVE-2019-12414?

3 open source packages ship an affected version, including apache-superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions0.32
apache-superset PyPIAll versions0.32.0
apache-superset PyPIAll versions0.32.0

Products include Apache Superset.

How do I fix CVE-2019-12414?

Upgrade apache-superset to a fixed version for your release line: 0.32 or 0.32.0.

Is CVE-2019-12414 being exploited?

There is no known exploitation of CVE-2019-12414 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as GHSA-9c29-9h4m-wg5p, PYSEC-2019-173.

Is CVE-2019-12414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free