# CVE-2019-12414: Users can view database names in Apache Superset

> An attacker can view unauthorized database names in the SQLLab dropdown list, exposing sensitive metadata.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9c29-9h4m-wg5p, PYSEC-2019-173

## What is CVE-2019-12414?

CVE-2019-12414 is a medium-severity vulnerability in Apache Superset, published on 16 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Incubator Superset before 0.32, a user can view database names that he has no access to on a dropdown list in SQLLab

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-12414?

3 open source packages ship an affected version, including apache-superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 0.32 |
| `apache-superset` | PyPI | All versions | 0.32.0 |
| `apache-superset` | PyPI | All versions | 0.32.0 |

Products: Apache Superset.

## How do I fix CVE-2019-12414?

Upgrade apache-superset to a fixed version for your release line: 0.32 or 0.32.0.

## Is CVE-2019-12414 being exploited?

There is no known exploitation of CVE-2019-12414 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12414 and fix it if it is affected.

What it is: CVE-2019-12414 is a medium-severity vulnerability in Apache Superset, published on 16 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12414 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 0.32
- apache-superset (PyPI): affected all versions; fixed in 0.32.0
- apache-superset (PyPI): affected all versions; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12414/ (Markdown: https://insights.sbomify.com/CVE-2019-12414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12414
- OSV: https://osv.dev/vulnerability/CVE-2019-12414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12414/
Summaries are generated and may contain mistakes; the official description above is the record.
