{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.deltaspike:deltaspike. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-12416 in the wild and no public exploit code.","fix":"Upgrade org.apache.deltaspike:deltaspike to 1.9.4 or later.","what":"CVE-2019-12416 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 19 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-12416 and fix it if it is affected.\n\nWhat it is: CVE-2019-12416 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 19 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-12416 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.deltaspike:deltaspike (Maven): affected all versions; fixed in 1.9.4\n- org.apache.deltaspike:deltaspike (Maven): affected all versions; fixed in 1.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12416/ (Markdown: https://insights.sbomify.com/CVE-2019-12416/index.md)","id":"CVE-2019-12416","markdown":"https://insights.sbomify.com/CVE-2019-12416/index.md","name":"CVE-2019-12416","record":{"aliases":["GHSA-rhg5-fqr3-hrf5"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Java CDI library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via injection in DeltaSpike windowhandler.js when ClientSideWindowStrategy is enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"deltaspike","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"we got reports for 2 injection attacks against the DeltaSpike windowhandler.js. This is only active if a developer selected the ClientSideWindowStrategy which is not the default.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Injection in DeltaSpike","id":"CVE-2019-12416","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Airflow vulnerable to XSS and local file disclosure","id":"CVE-2019-12417"},"packages":[{"ecosystem":"Maven","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.deltaspike:deltaspike","purl":null,"source":"GHSA-rhg5-fqr3-hrf5"},{"ecosystem":"Maven","fixed":["1.9.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.deltaspike:deltaspike","purl":"pkg:maven/org.apache.deltaspike/deltaspike","source":"GHSA-rhg5-fqr3-hrf5"}],"prev":{"headline":"Improper Restriction of XML External Entity Reference in Apache POI","id":"CVE-2019-12415"},"products":["Apache DeltaSpike"],"published":"2020-03-19","related":[{"cvss_score":6.1,"headline":"Cross-site Scripting in Apache DeltaSpike","id":"CVE-2017-17837","kev_date_added":null,"published":"2018-01-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via injection in DeltaSpike windowhandler.js when ClientSideWindowStrategy is enabled.","url":"https://insights.sbomify.com/CVE-2019-12416/"}