# CVE-2019-12416: Injection in DeltaSpike

> Attackers can execute arbitrary scripts via injection in DeltaSpike windowhandler.js when ClientSideWindowStrategy is enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rhg5-fqr3-hrf5

## What is CVE-2019-12416?

CVE-2019-12416 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 19 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

we got reports for 2 injection attacks against the DeltaSpike windowhandler.js. This is only active if a developer selected the ClientSideWindowStrategy which is not the default.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-12416?

2 open source packages ship an affected version, including org.apache.deltaspike:deltaspike. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.deltaspike:deltaspike` | Maven | All versions | 1.9.4 |
| `org.apache.deltaspike:deltaspike` | Maven | All versions | 1.9.4 |

Products: Apache Deltaspike.

## How do I fix CVE-2019-12416?

Upgrade org.apache.deltaspike:deltaspike to 1.9.4 or later.

## Is CVE-2019-12416 being exploited?

There is no known exploitation of CVE-2019-12416 in the wild and no public exploit code.

## Other vulnerabilities in Apache DeltaSpike

- [CVE-2017-17837](https://insights.sbomify.com/CVE-2017-17837/): Cross-site Scripting in Apache DeltaSpike (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12416 and fix it if it is affected.

What it is: CVE-2019-12416 is a medium-severity cross-site scripting vulnerability in Apache DeltaSpike, published on 19 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12416 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.deltaspike:deltaspike (Maven): affected all versions; fixed in 1.9.4
- org.apache.deltaspike:deltaspike (Maven): affected all versions; fixed in 1.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12416/ (Markdown: https://insights.sbomify.com/CVE-2019-12416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12416
- OSV: https://osv.dev/vulnerability/CVE-2019-12416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12416/
Summaries are generated and may contain mistakes; the official description above is the record.
