{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-12420 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-12420 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-12420 and fix it if it is affected.\n\nWhat it is: CVE-2019-12420 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 12 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-12420 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12420/ (Markdown: https://insights.sbomify.com/CVE-2019-12420/index.md)","id":"CVE-2019-12420","markdown":"https://insights.sbomify.com/CVE-2019-12420/index.md","name":"CVE-2019-12420","record":{"aliases":["ALPINE-CVE-2019-12420","DEBIAN-CVE-2019-12420","GHSA-q6ww-c56f-5fhw","RHSA-2020:3973","UBUNTU-CVE-2019-12420"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SpamAssassin mail filter","requires_auth":"none","summary":"Attackers can craft messages to exhaust resources in Apache SpamAssassin, causing denial of service; administrators should upgrade immediately.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"spamassassin","vendor":"apache"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"In Apache SpamAssassin before 3.4.3, a message can be crafted in a way to use excessive resources. Upgrading to SA 3.4.3 as soon as possible is the recommended fix but details will not be shared publicly.","ecosystems":["Red Hat:enterprise_linux:7::client","Red Hat:enterprise_linux:7::server","Red Hat:enterprise_linux:7::workstation"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Apache SpamAssassin","id":"CVE-2019-12420","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"denial_of_service","year":"2019"},"n_packages":6,"n_references":14,"next":{"headline":"Apache NiFi user log out issue","id":"CVE-2019-12421"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["0:3.4.0-6.el7"],"introduced":["0"],"last_affected":[],"package":"spamassassin","purl":"pkg:rpm/redhat/spamassassin","source":"RHSA-2020:3973"},{"ecosystem":"Red Hat:enterprise_linux:7::client","fixed":["0:3.4.0-6.el7"],"introduced":["0"],"last_affected":[],"package":"spamassassin-debuginfo","purl":"pkg:rpm/redhat/spamassassin-debuginfo","source":"RHSA-2020:3973"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:3.4.0-6.el7"],"introduced":["0"],"last_affected":[],"package":"spamassassin","purl":"pkg:rpm/redhat/spamassassin","source":"RHSA-2020:3973"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:3.4.0-6.el7"],"introduced":["0"],"last_affected":[],"package":"spamassassin-debuginfo","purl":"pkg:rpm/redhat/spamassassin-debuginfo","source":"RHSA-2020:3973"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:3.4.0-6.el7"],"introduced":["0"],"last_affected":[],"package":"spamassassin","purl":"pkg:rpm/redhat/spamassassin","source":"RHSA-2020:3973"},{"ecosystem":"Red Hat:enterprise_linux:7::workstation","fixed":["0:3.4.0-6.el7"],"introduced":["0"],"last_affected":[],"package":"spamassassin-debuginfo","purl":"pkg:rpm/redhat/spamassassin-debuginfo","source":"RHSA-2020:3973"}],"prev":{"headline":"Potential session hijack in Apache CXF","id":"CVE-2019-12419"},"products":["Apache SpamAssassin"],"published":"2019-12-12","related":[{"cvss_score":9.8,"headline":"Apache SpamAssassin has an OS Command Injection vulnerability","id":"CVE-2020-1946","kev_date_added":null,"published":"2021-03-25"},{"cvss_score":9.8,"headline":"Code injection in Apache SpamAssassin","id":"CVE-2018-11780","kev_date_added":null,"published":"2018-09-17"},{"cvss_score":8.1,"headline":"Command injection in Apache SpamAssassin","id":"CVE-2020-1930","kev_date_added":null,"published":"2020-01-30"},{"cvss_score":8.1,"headline":"Command injection in Apache SpamAssassin","id":"CVE-2020-1931","kev_date_added":null,"published":"2020-01-30"},{"cvss_score":7.8,"headline":"Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.","id":"CVE-2018-11781","kev_date_added":null,"published":"2018-09-17"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2016-1238","kev_date_added":null,"published":"2016-08-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache"]},"summary":"Attackers can craft messages to exhaust resources in Apache SpamAssassin, causing denial of service; administrators should upgrade immediately.","url":"https://insights.sbomify.com/CVE-2019-12420/"}