# CVE-2019-12421: Apache NiFi user log out issue

> Attackers can reuse client-side tokens for up to 12 hours after logout in non-PKI configurations, bypassing session invalidation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fmqw-vqh5-cwq9

## What is CVE-2019-12421?

CVE-2019-12421 is a high-severity vulnerability in Apache Nifi, published on 19 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When using an authentication mechanism other than PKI, when the user clicks Log Out in NiFi versions 1.0.0 to 1.9.2, NiFi invalidates the authentication token on the client side but not on the server side. This permits the user's client-side token to be used for up to 12 hours after logging out to make API requests to NiFi.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2019-12421?

4 open source packages ship an affected version, including org.apache.nifi:nifi-web-api and org.apache.nifi:nifi-web-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.3.0 | 1.10.0 |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.3.0 | 1.10.0 |
| `org.apache.nifi:nifi-web-security` | Maven | From 1.3.0 | 1.10.0 |
| `org.apache.nifi:nifi-web-security` | Maven | From 1.3.0 | 1.10.0 |

Products: Apache Nifi.

## How do I fix CVE-2019-12421?

Upgrade org.apache.nifi:nifi-web-api to 1.10.0 or later.

## Is CVE-2019-12421 being exploited?

There is no known exploitation of CVE-2019-12421 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12421 and fix it if it is affected.

What it is: CVE-2019-12421 is a high-severity vulnerability in Apache Nifi, published on 19 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12421 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-web-api (Maven): affected from 1.3.0; fixed in 1.10.0
- org.apache.nifi:nifi-web-api (Maven): affected from 1.3.0; fixed in 1.10.0
- org.apache.nifi:nifi-web-security (Maven): affected from 1.3.0; fixed in 1.10.0
- org.apache.nifi:nifi-web-security (Maven): affected from 1.3.0; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12421/ (Markdown: https://insights.sbomify.com/CVE-2019-12421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12421
- OSV: https://osv.dev/vulnerability/CVE-2019-12421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12421/
Summaries are generated and may contain mistakes; the official description above is the record.
