CVE-2019-12437 Silverstripe CSRF Protection Bypass via GraphQL

High 8.8 Published Updated

Insufficient CSRF protection in SilverStripe GraphQL mutations allows attackers to perform unauthorized actions on behalf of authenticated users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-12437?

CVE-2019-12437 is a high-severity vulnerability in Silverstripe Silverstripe, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations,

Weakness: CWE-352

Which versions are affected by CVE-2019-12437?

4 open source packages ship an affected version, including silverstripe/graphql. It affects 1 product.

PackageAffectedFixed in
silverstripe/graphql PackagistFrom 2.0.02.0.5
silverstripe/graphql PackagistFrom 2.0.02.0.5
silverstripe/graphql PackagistFrom 3.1.03.1.2
silverstripe/graphql PackagistFrom 3.1.03.1.2

Products include Silverstripe Silverstripe.

How do I fix CVE-2019-12437?

Upgrade silverstripe/graphql to a fixed version for your release line: 2.0.5 or 3.1.2.

Is CVE-2019-12437 being exploited?

There is no known exploitation of CVE-2019-12437 in the wild and no public exploit code.

All Silverstripe Silverstripe vulnerabilities

Sources

Also known as GHSA-fx37-56v6-85q6.

Is CVE-2019-12437 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free