# CVE-2019-12437: Silverstripe CSRF Protection Bypass via GraphQL

> Insufficient CSRF protection in SilverStripe GraphQL mutations allows attackers to perform unauthorized actions on behalf of authenticated users.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fx37-56v6-85q6

## What is CVE-2019-12437?

CVE-2019-12437 is a high-severity vulnerability in Silverstripe Silverstripe, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely mitigate the risk of CSRF in GraphQL mutations,

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-12437?

4 open source packages ship an affected version, including silverstripe/graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/graphql` | Packagist | From 2.0.0 | 2.0.5 |
| `silverstripe/graphql` | Packagist | From 2.0.0 | 2.0.5 |
| `silverstripe/graphql` | Packagist | From 3.1.0 | 3.1.2 |
| `silverstripe/graphql` | Packagist | From 3.1.0 | 3.1.2 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-12437?

Upgrade silverstripe/graphql to a fixed version for your release line: 2.0.5 or 3.1.2.

## Is CVE-2019-12437 being exploited?

There is no known exploitation of CVE-2019-12437 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)
- [CVE-2020-9280](https://insights.sbomify.com/CVE-2020-9280/): SilverStripe Folders migrated from 3.x may be unsafe to upload to (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12437 and fix it if it is affected.

What it is: CVE-2019-12437 is a high-severity vulnerability in Silverstripe Silverstripe, published on 19 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12437 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/graphql (Packagist): affected from 2.0.0; fixed in 2.0.5
- silverstripe/graphql (Packagist): affected from 2.0.0; fixed in 2.0.5
- silverstripe/graphql (Packagist): affected from 3.1.0; fixed in 3.1.2
- silverstripe/graphql (Packagist): affected from 3.1.0; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12437/ (Markdown: https://insights.sbomify.com/CVE-2019-12437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12437
- OSV: https://osv.dev/vulnerability/CVE-2019-12437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12437/
Summaries are generated and may contain mistakes; the official description above is the record.
