{"answers":{"affected":"2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-12463 in the wild and no public exploit code.","fix":"Upgrade librenms/librenms to 1.53 or later.","what":"CVE-2019-12463 is a high-severity command injection vulnerability in Librenms Librenms, published on 9 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-12463 and fix it if it is affected.\n\nWhat it is: CVE-2019-12463 is a high-severity command injection vulnerability in Librenms Librenms, published on 9 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-12463 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- librenms/librenms (Packagist): affected from 1.50.1; fixed in 1.53\n- librenms/librenms (Packagist): affected from 1.50.1; fixed in 1.53\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12463/ (Markdown: https://insights.sbomify.com/CVE-2019-12463/index.md)","id":"CVE-2019-12463","markdown":"https://insights.sbomify.com/CVE-2019-12463/index.md","name":"CVE-2019-12463","record":{"aliases":["GHSA-w5r2-gvgf-mpm8"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LibreNMS network monitoring","requires_auth":"low_privilege","summary":"Authenticated attackers can inject RRDtool syntax via graph parameters to execute commands, read files, or cause denial of service in LibreNMS.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"librenms","vendor":"librenms"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"An issue was discovered in LibreNMS 1.50.1. The scripts that handle graphing options (includes/html/graphs/common.inc.php and includes/html/graphs/graphs.inc.php) do not sufficiently validate or encode several fields of user supplied input. Some parameters are filtered with mysqli_real_escape_string, which is only useful for preventing SQL injection attacks; other parameters are unfiltered. This allows an attacker to inject RRDtool syntax with newline characters via the html/graph.php and html/graph-realtime.php scripts. RRDtool syntax is quite versatile and an attacker could leverage this to perform a number of attacks, including disclosing directory structure and filenames, disclosing file content, denial of service, or writing arbitrary files. NOTE: relative to CVE-2019-10665, this requires authentication and the pathnames differ.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Encoding or Escaping of Output and Injection in LibreNMS","id":"CVE-2019-12463","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"librenms:librenms","products":["librenms:librenms"],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Path Traversal in LibreNMS","id":"CVE-2019-12464"},"packages":[{"ecosystem":"Packagist","fixed":["1.53"],"introduced":["1.50.1"],"last_affected":[],"package":"librenms/librenms","purl":null,"source":"GHSA-w5r2-gvgf-mpm8"},{"ecosystem":"Packagist","fixed":["1.53"],"introduced":["1.50.1"],"last_affected":[],"package":"librenms/librenms","purl":"pkg:composer/librenms/librenms","source":"GHSA-w5r2-gvgf-mpm8"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-12461"},"products":["n/a"],"published":"2019-09-09","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in librenms/librenms","id":"CVE-2023-4982","kev_date_added":null,"published":"2023-09-15"},{"cvss_score":9.8,"headline":"Command injection in librenms","id":"CVE-2022-29712","kev_date_added":null,"published":"2022-05-31"},{"cvss_score":9.8,"headline":"Path traversal in librenms/librenms","id":"CVE-2021-44278","kev_date_added":null,"published":"2021-12-03"},{"cvss_score":9.8,"headline":"LibreNMS Information Disclosure","id":"CVE-2019-10665","kev_date_added":null,"published":"2019-09-09"},{"cvss_score":9.8,"headline":"LibreNMS arbitrary OS commands execution","id":"CVE-2018-20434","kev_date_added":null,"published":"2019-04-24"},{"cvss_score":9.3,"headline":"LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream","id":"CVE-2026-26988","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":9.2,"headline":"LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion","id":"CVE-2026-86426","kev_date_added":null,"published":"2026-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Authenticated attackers can inject RRDtool syntax via graph parameters to execute commands, read files, or cause denial of service in LibreNMS.","url":"https://insights.sbomify.com/CVE-2019-12463/"}