# CVE-2019-12463: Improper Encoding or Escaping of Output and Injection in LibreNMS

> Authenticated attackers can inject RRDtool syntax via graph parameters to execute commands, read files, or cause denial of service in LibreNMS.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w5r2-gvgf-mpm8

## What is CVE-2019-12463?

CVE-2019-12463 is a high-severity command injection vulnerability in Librenms Librenms, published on 9 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in LibreNMS 1.50.1. The scripts that handle graphing options (includes/html/graphs/common.inc.php and includes/html/graphs/graphs.inc.php) do not sufficiently validate or encode several fields of user supplied input. Some parameters are filtered with mysqli_real_escape_string, which is only useful for preventing SQL injection attacks; other parameters are unfiltered. This allows an attacker to inject RRDtool syntax with newline characters via the html/graph.php and html/graph-realtime.php scripts. RRDtool syntax is quite versatile and an attacker could leverage this to perform a number of attacks, including disclosing directory structure and filenames, disclosing file content, denial of service, or writing arbitrary files. NOTE: relative to CVE-2019-10665, this requires authentication and the pathnames differ.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2019-12463?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | From 1.50.1 | 1.53 |
| `librenms/librenms` | Packagist | From 1.50.1 | 1.53 |

Products: Librenms Librenms.

## How do I fix CVE-2019-12463?

Upgrade librenms/librenms to 1.53 or later.

## Is CVE-2019-12463 being exploited?

There is no known exploitation of CVE-2019-12463 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12463 and fix it if it is affected.

What it is: CVE-2019-12463 is a high-severity command injection vulnerability in Librenms Librenms, published on 9 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12463 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected from 1.50.1; fixed in 1.53
- librenms/librenms (Packagist): affected from 1.50.1; fixed in 1.53

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12463/ (Markdown: https://insights.sbomify.com/CVE-2019-12463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12463
- OSV: https://osv.dev/vulnerability/CVE-2019-12463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12463/
Summaries are generated and may contain mistakes; the official description above is the record.
