CVE-2019-12466 Wikimedia MediaWiki allows CSRF
Attackers can perform unauthorized actions on behalf of authenticated users in MediaWiki installations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-12466?
CVE-2019-12466 is a high-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Wikimedia MediaWiki through 1.32.1 allows CSRF.
Weakness: CWE-352
Which versions are affected by CVE-2019-12466?
8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
2 more packages
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2019-12466?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.
Is CVE-2019-12466 being exploited?
There is no known exploitation of CVE-2019-12466 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-12466, GHSA-27fw-r78j-h898, UBUNTU-CVE-2019-12466.