# CVE-2019-12467: MediaWiki Incorrect Access Control vulnerability

> Attackers can send unlimited spam emails via Special:ChangeEmail due to missing rate limiting, affecting MediaWiki administrators.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-12467, GHSA-6vfg-8ppv-h5hg, UBUNTU-CVE-2019-12467

## What is CVE-2019-12467?

CVE-2019-12467 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

## Which versions are affected by CVE-2019-12467?

8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | All versions | 1.27.6 |
| `mediawiki/core` | Packagist | All versions | 1.27.6 |
| `mediawiki/core` | Packagist | From 1.30.0 | 1.30.2 |
| `mediawiki/core` | Packagist | From 1.30.0 | 1.30.2 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.2 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.2 |
| `mediawiki/core` | Packagist | From 1.32.0 | 1.32.2 |
| `mediawiki/core` | Packagist | From 1.32.0 | 1.32.2 |

Products: Debian Debian Linux, Mediawiki Mediawiki.

## How do I fix CVE-2019-12467?

Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.

## Is CVE-2019-12467 being exploited?

There is no known exploitation of CVE-2019-12467 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12467 and fix it if it is affected.

What it is: CVE-2019-12467 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12467 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected all versions; fixed in 1.27.6
- mediawiki/core (Packagist): affected all versions; fixed in 1.27.6
- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2
- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2
- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2
- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12467/ (Markdown: https://insights.sbomify.com/CVE-2019-12467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12467
- OSV: https://osv.dev/vulnerability/CVE-2019-12467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12467/
Summaries are generated and may contain mistakes; the official description above is the record.
