CVE-2019-12468 Wikimedia MediaWiki Incorrect Access Control vulnerability
Attackers can bypass re-authentication in MediaWiki by directly POSTing to the change email endpoint, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-12468?
CVE-2019-12468 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.
Weakness: CWE-306
Which versions are affected by CVE-2019-12468?
8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
2 more packages
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2019-12468?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-12468 being exploited?
There is no known exploitation of CVE-2019-12468 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-12468, GHSA-wrhx-3pxr-6vgg, UBUNTU-CVE-2019-12468.