CVE-2019-12469 MediaWiki Incorrect Access Control vulnerability
MediaWiki exposes suppressed usernames and logs in Special:EditTags, allowing attackers to view hidden user data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-12469?
CVE-2019-12469 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
MediaWiki through 1.32.1 has Incorrect Access Control. Suppressed username or log in Special:EditTags are exposed. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Weakness: CWE-862
Which versions are affected by CVE-2019-12469?
8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
2 more packages
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2019-12469?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.
Is CVE-2019-12469 being exploited?
There is no known exploitation of CVE-2019-12469 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-12469, GHSA-x3fr-w7r5-x7rg, UBUNTU-CVE-2019-12469.