# CVE-2019-12469: MediaWiki Incorrect Access Control vulnerability

> MediaWiki exposes suppressed usernames and logs in Special:EditTags, allowing attackers to view hidden user data.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-12469, GHSA-x3fr-w7r5-x7rg, UBUNTU-CVE-2019-12469

## What is CVE-2019-12469?

CVE-2019-12469 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MediaWiki through 1.32.1 has Incorrect Access Control. Suppressed username or log in Special:EditTags are exposed. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-12469?

8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | From 1.27.0 | 1.27.6 |
| `mediawiki/core` | Packagist | From 1.27.0 | 1.27.6 |
| `mediawiki/core` | Packagist | From 1.30.0 | 1.30.2 |
| `mediawiki/core` | Packagist | From 1.30.0 | 1.30.2 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.2 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.2 |
| `mediawiki/core` | Packagist | From 1.32.0 | 1.32.2 |
| `mediawiki/core` | Packagist | From 1.32.0 | 1.32.2 |

Products: Debian Debian Linux, Mediawiki Mediawiki.

## How do I fix CVE-2019-12469?

Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.

## Is CVE-2019-12469 being exploited?

There is no known exploitation of CVE-2019-12469 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12469 and fix it if it is affected.

What it is: CVE-2019-12469 is a medium-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-12469 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.6
- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.6
- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2
- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2
- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2
- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12469/ (Markdown: https://insights.sbomify.com/CVE-2019-12469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12469
- OSV: https://osv.dev/vulnerability/CVE-2019-12469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12469/
Summaries are generated and may contain mistakes; the official description above is the record.
