CVE-2019-12471 MediaWiki Cross-site Scripting (XSS)
Attackers can perform cross-site scripting by creating accounts with specific names, potentially compromising user sessions in MediaWiki.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-12471?
CVE-2019-12471 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Weakness: CWE-79
Which versions are affected by CVE-2019-12471?
6 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2019-12471?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2 or 1.31.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-12471 being exploited?
There is no known exploitation of CVE-2019-12471 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-12471, GHSA-2rm7-xxx8-35jh, UBUNTU-CVE-2019-12471.