CVE-2019-12472 MediaWiki Incorrect Access Control vulnerability
Attackers can bypass IP range block limits in MediaWiki via the API, allowing unauthorized access from blocked ranges.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-12472?
CVE-2019-12472 is a high-severity vulnerability in Mediawiki Mediawiki, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Which versions are affected by CVE-2019-12472?
8 open source packages ship an affected version, including mediawiki/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.18.0 | 1.27.6 |
mediawiki/core Packagist | From 1.18.0 | 1.27.6 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
2 more packages
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2019-12472?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.
Is CVE-2019-12472 being exploited?
There is no known exploitation of CVE-2019-12472 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as DEBIAN-CVE-2019-12472, GHSA-7mqg-5fgh-xh4r, UBUNTU-CVE-2019-12472.