{"answers":{"affected":"8 open source packages ship an affected version, including mediawiki/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-12472 in the wild and no public exploit code.","fix":"Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.","what":"CVE-2019-12472 is a high-severity vulnerability in Mediawiki Mediawiki, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-12472 and fix it if it is affected.\n\nWhat it is: CVE-2019-12472 is a high-severity vulnerability in Mediawiki Mediawiki, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-12472 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki/core (Packagist): affected from 1.18.0; fixed in 1.27.6\n- mediawiki/core (Packagist): affected from 1.18.0; fixed in 1.27.6\n- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2\n- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2\n- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2\n- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12472/ (Markdown: https://insights.sbomify.com/CVE-2019-12472/index.md)","id":"CVE-2019-12472","markdown":"https://insights.sbomify.com/CVE-2019-12472/index.md","name":"CVE-2019-12472","record":{"aliases":["DEBIAN-CVE-2019-12472","GHSA-7mqg-5fgh-xh4r","UBUNTU-CVE-2019-12472"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"none","summary":"Attackers can bypass IP range block limits in MediaWiki via the API, allowing unauthorized access from blocked ranges.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[],"description":"An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MediaWiki Incorrect Access Control vulnerability","id":"CVE-2019-12472","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"mediawiki:mediawiki","products":["mediawiki:mediawiki"],"type":"security_feature_bypass","year":"2019"},"n_packages":8,"n_references":2,"next":{"headline":"Wikimedia Potential DOS due to slow WatchedItemStore::countVisitingWatchersMultiple","id":"CVE-2019-12473"},"packages":[{"ecosystem":"Packagist","fixed":["1.27.6"],"introduced":["1.18.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.27.6"],"introduced":["1.18.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.30.2"],"introduced":["1.30.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.30.2"],"introduced":["1.30.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.32.2"],"introduced":["1.32.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-7mqg-5fgh-xh4r"},{"ecosystem":"Packagist","fixed":["1.32.2"],"introduced":["1.32.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-7mqg-5fgh-xh4r"}],"prev":{"headline":"MediaWiki Cross-site Scripting (XSS)","id":"CVE-2019-12471"},"products":["n/a"],"published":"2019-07-10","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2023-37303","kev_date_added":null,"published":"2023-06-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-29904","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-29906","kev_date_added":null,"published":"2022-04-29"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2022-28205","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28206","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-28209","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"Business logic in n/a","id":"CVE-2021-36126","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass IP range block limits in MediaWiki via the API, allowing unauthorized access from blocked ranges.","url":"https://insights.sbomify.com/CVE-2019-12472/"}