CVE-2019-12473 Wikimedia Potential DOS due to slow WatchedItemStore::countVisitingWatchersMultiple
Attackers can cause denial of service in MediaWiki by passing invalid titles to the API, triggering expensive database queries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-12473?
CVE-2019-12473 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Wikimedia MediaWiki 1.27.0 through 1.32.1 might allow DoS. Passing invalid titles to the API could cause a DoS by querying the entire watchlist table. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Which versions are affected by CVE-2019-12473?
8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.27.0 | 1.27.6 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.30.0 | 1.30.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
mediawiki/core Packagist | From 1.31.0 | 1.31.2 |
2 more packages
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
mediawiki/core Packagist | From 1.32.0 | 1.32.2 |
Products include Debian Debian Linux, Mediawiki Mediawiki.
How do I fix CVE-2019-12473?
Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-12473 being exploited?
There is no known exploitation of CVE-2019-12473 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-12473, GHSA-33xw-x3pr-rvqj, UBUNTU-CVE-2019-12473.