{"answers":{"affected":"8 open source packages ship an affected version, including mediawiki/core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-12474 in the wild and no public exploit code.","fix":"Upgrade mediawiki/core to a fixed version for your release line: 1.27.6, 1.30.2, 1.31.2 or 1.32.2.","what":"CVE-2019-12474 is a high-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-12474 and fix it if it is affected.\n\nWhat it is: CVE-2019-12474 is a high-severity vulnerability in Debian Debian Linux, published on 10 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-12474 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.6\n- mediawiki/core (Packagist): affected from 1.27.0; fixed in 1.27.6\n- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2\n- mediawiki/core (Packagist): affected from 1.30.0; fixed in 1.30.2\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.2\n- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2\n- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.32.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12474/ (Markdown: https://insights.sbomify.com/CVE-2019-12474/index.md)","id":"CVE-2019-12474","markdown":"https://insights.sbomify.com/CVE-2019-12474/index.md","name":"CVE-2019-12474","record":{"aliases":["DEBIAN-CVE-2019-12474","GHSA-2qrr-c2gh-pr35","UBUNTU-CVE-2019-12474"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"none","summary":"Privileged API responses indicating recent change patrol status may be publicly cached, leaking sensitive information to unauthorized users.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[],"description":"Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wikimedia information leak vulnerability","id":"CVE-2019-12474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","mediawiki:mediawiki"],"type":"information_disclosure","year":"2019"},"n_packages":8,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-12475"},"packages":[{"ecosystem":"Packagist","fixed":["1.27.6"],"introduced":["1.27.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.27.6"],"introduced":["1.27.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.30.2"],"introduced":["1.30.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.30.2"],"introduced":["1.30.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.31.2"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.32.2"],"introduced":["1.32.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-2qrr-c2gh-pr35"},{"ecosystem":"Packagist","fixed":["1.32.2"],"introduced":["1.32.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-2qrr-c2gh-pr35"}],"prev":{"headline":"Wikimedia Potential DOS due to slow WatchedItemStore::countVisitingWatchersMultiple","id":"CVE-2019-12473"},"products":["n/a"],"published":"2019-07-10","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Privileged API responses indicating recent change patrol status may be publicly cached, leaking sensitive information to unauthorized users.","url":"https://insights.sbomify.com/CVE-2019-12474/"}