{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-12562 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to 9.4.0 or later.","what":"CVE-2019-12562 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 26 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-12562 and fix it if it is affected.\n\nWhat it is: CVE-2019-12562 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 26 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-12562 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.4.0\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-12562/ (Markdown: https://insights.sbomify.com/CVE-2019-12562/index.md)","id":"CVE-2019-12562","markdown":"https://insights.sbomify.com/CVE-2019-12562/index.md","name":"CVE-2019-12562","record":{"aliases":["GHSA-5whq-j5qg-wjvp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetNuke CMS","requires_auth":"none","summary":"Stored XSS in DotNetNuke allows attackers to execute scripts in admin sessions, leading to privilege escalation and potential server compromise.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Stored Cross-Site Scripting in DotNetNuke (DNN) Version before 9.4.0 allows remote attackers to store and embed the malicious script into the admin notification page. The exploit could be used to perfom any action with admin privileges such as managing content, adding users, uploading backdoors to the server, etc. Successful exploitation occurs when an admin user visits a notification page with stored cross-site scripting.","ecosystems":["NuGet"],"exploits":{"exploitdb":1,"first_seen":"2019-10-01","github_poc":1,"max_poc_stars":8,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-10-03T16:29:58Z","kind":"github_poc","ref":"https://github.com/MAYASEVEN/CVE-2019-12562","stars":8,"title":"Stored Cross-Site Scripting in DotNetNuke (DNN) Version before 9.4.0 | XSS to RCE"},{"date":"2019-10-01","kind":"exploitdb","ref":"47448","stars":null,"title":"DotNetNuke \u003c 9.4.0 - Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Stored Cross-Site Scripting vulnerability in admin component of DotNetNuke","id":"CVE-2019-12562","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"xss","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2019-12564"},"packages":[{"ecosystem":"NuGet","fixed":["9.4.0"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-5whq-j5qg-wjvp"},{"ecosystem":"NuGet","fixed":["9.4.0"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-5whq-j5qg-wjvp"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2019-12555"},"products":["n/a"],"published":"2019-09-26","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Stored XSS in DotNetNuke allows attackers to execute scripts in admin sessions, leading to privilege escalation and potential server compromise.","url":"https://insights.sbomify.com/CVE-2019-12562/"}