# CVE-2019-12562: Stored Cross-Site Scripting vulnerability in admin component of DotNetNuke

> Stored XSS in DotNetNuke allows attackers to execute scripts in admin sessions, leading to privilege escalation and potential server compromise.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5whq-j5qg-wjvp

## What is CVE-2019-12562?

CVE-2019-12562 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 26 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Stored Cross-Site Scripting in DotNetNuke (DNN) Version before 9.4.0 allows remote attackers to store and embed the malicious script into the admin notification page. The exploit could be used to perfom any action with admin privileges such as managing content, adding users, uploading backdoors to the server, etc. Successful exploitation occurs when an admin user visits a notification page with stored cross-site scripting.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-12562?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.4.0 |
| `DotNetNuke.Core` | NuGet | All versions | 9.4.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2019-12562?

Upgrade DotNetNuke.Core to 9.4.0 or later.

## Is CVE-2019-12562 being exploited?

There is no known exploitation of CVE-2019-12562 in the wild and no public exploit code.

Public exploit code:

- Stored Cross-Site Scripting in DotNetNuke (DNN) Version before 9.4.0 | XSS to RCE (github_poc): https://github.com/MAYASEVEN/CVE-2019-12562
- DotNetNuke < 9.4.0 - Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12562 and fix it if it is affected.

What it is: CVE-2019-12562 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 26 Sep 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12562 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.4.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12562/ (Markdown: https://insights.sbomify.com/CVE-2019-12562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12562
- OSV: https://osv.dev/vulnerability/CVE-2019-12562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12562/
Summaries are generated and may contain mistakes; the official description above is the record.
