# CVE-2019-12616: phpMyAdmin CSRF Vulnerability

> An attacker can trick a phpMyAdmin user into executing unauthorized database commands via CSRF, potentially modifying or reading data.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-12616, GHSA-mfr9-pcm3-6mwc, UBUNTU-CVE-2019-12616

## What is CVE-2019-12616?

CVE-2019-12616 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in phpMyAdmin before 4.9.0. A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) to the victim.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-12616?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.9.0 |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.9.0 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2019-12616?

Upgrade phpmyadmin/phpmyadmin to 4.9.0 or later.

## Is CVE-2019-12616 being exploited?

There is no known exploitation of CVE-2019-12616 in the wild and no public exploit code.

Public exploit code:

- phpMyAdmin <4.9.0 - Cross-Site Request Forgery (github_poc): https://github.com/Cappricio-Securities/CVE-2019-12616
- phpMyAdmin 4.8 - Cross-Site Request Forgery (exploitdb)

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-12616 and fix it if it is affected.

What it is: CVE-2019-12616 is a medium-severity vulnerability in Phpmyadmin Phpmyadmin, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-12616 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.9.0
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-12616/ (Markdown: https://insights.sbomify.com/CVE-2019-12616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-12616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-12616
- OSV: https://osv.dev/vulnerability/CVE-2019-12616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-12616/
Summaries are generated and may contain mistakes; the official description above is the record.
