CVE-2019-12617 SilverStripe Priviledge escalation through cache pollution
Attackers with limited CMS access can escalate privileges via permission cache pollution in SilverStripe.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-12617?
CVE-2019-12617 is a low-severity vulnerability in Silverstripe Silverstripe, published on 26 Sep 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
In SilverStripe through 4.3.3, there is access escalation for CMS users with limited access through permission cache pollution.
Which versions are affected by CVE-2019-12617?
4 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/framework Packagist | From 4.3.0 | 4.3.5 |
silverstripe/framework Packagist | From 4.3.0 | 4.3.5 |
silverstripe/framework Packagist | From 4.4.0 | 4.4.4 |
silverstripe/framework Packagist | From 4.4.0 | 4.4.4 |
Products include Silverstripe Silverstripe.
How do I fix CVE-2019-12617?
Upgrade silverstripe/framework to a fixed version for your release line: 4.3.5 or 4.4.4.
Is CVE-2019-12617 being exploited?
There is no known exploitation of CVE-2019-12617 in the wild and no public exploit code.
Other vulnerabilities in Silverstripe Silverstripe
Sources
Also known as GHSA-6r58-4xgr-gm6m.